Skip to content. | Skip to navigation

Personal tools
Log in
Sections
You are here: Home Blog Smaller Blocks

Smaller Blocks

Posted by Manuel Reinhardt at Apr 27, 2011 08:05 PM |

A post in the gentoo forums just helped me realize that blocks with a leading "<", e.g.

[blocks B     ] <dev-libs/libxml2-2.7.7 ("<dev-libs/libxml2-2.7.7" is blocking sys-libs/zlib-1.2.4) 

are quite easy to resolve by first upgrading the blocking package to a version newer than the specified one (2.7.7 in this case) and then proceeding with the original merge.

reinhardt@floyd ~ $ emerge -av1 libxml2 && emerge --update world

Writing this post helped me realize that escaping "<" can be important.